Cubase Essential 4

Works fine in 10.8

Works fine in 10.7

Cubase Essential 4

Supports iCloud

Secured by Gatekeeper

Supports retina graphics

Cubase Essential 4 icon

Available on the Mac App Store
Not available on the Mac App Store

Haven't found anything that doesn't work yet.

Version 4.5.2
Developer Steinberg
Status Works fine

0 ratings

Archived comments

No comments.0 comments