iStat Pro

Some problems in 10.8

Works fine in 10.7

iStat Pro

Supports iCloud

Secured by Gatekeeper

Supports retina graphics

iStat Pro icon

Available on the Mac App Store
Not available on the Mac App Store

cant download wiget

Version 4.92
Developer iSlayer
Website http://www.islayer.com/apps/istatpro/
Status Some problems

0 ratings

Under Mountain Lion, the processes section is showing blank squares instead of a list, and other sections are missing entirely.

It's easy to fix iStat Pro processes for Mountain Lion

Steps:

1. Locate your widget, it will be under /Library/Widgets or ~/Library/Widgets
2. Right click it and select: "Show Package Contents"
3. Open Wide.js or Tall.js file in some editor (Wide is for horizontal view, Tall for vertical)

4. Locate the line

Quote:
WideSkinController.prototype.updateProcesses = function(){
var _self = this;
var exclude = "";
if(p.v("processes_excludewidgets") == 'on')
exclude = " grep -v DashboardClient | ";

if(p.v("processes_sort_mode") == 'cpu')
widget.system('ps -arcwwwxo "pid %cpu command" | egrep "PID|$1" | grep -v grep | ' + exclude + ' head -7 | tail -6 | awk \'{print "<pid>"$1"</pid><cpu>"$2"</cpu><name>"$3,$4,$5"</name></item>"}\'', function(data){ _self.updateProcessesOut(data);});
else
widget.system('ps -amcwwwxo "pid rss command" | egrep "PID|$1" | grep -v grep | ' + exclude + ' head -7 | tail -6 | awk \'{print "<pid>"$1"</pid><cpu>"$2"</cpu><name>"$3,$4,$5"</name></item>"}\'', function(data){ _self.updateProcessesOut(data);});
}

Change "PID|$1" to "PID| $1" (Add space before $ sign)

5. Save the changes

6. remove widget and re-add it Dashboard, and it should be fixed

Archived comments

No comments.20 comments

Florian BeerFlorian BeerAnonymous 26 Jul 2012 12:58

Here's how to fix the process view in iStats Pro for Mountain Lion:
http://forums.macrumors.com/showthread.php?t=1325546

Edit | Permalink


Brent SordylBrent SordylAnonymous 26 Jul 2012 13:56

Here's a direct link to the fix, its a simple text edit and it worked for me.

http://forums.macrumors.com/showpost.php?p=15332289&postcount=20

Edit | Permalink


[ bob]bobAnonymous 27 Jul 2012 17:15

nice thanks

Edit | Permalink


[ Hannes Oud]Hannes OudAnonymous 27 Jul 2012 18:14

thanks, the fix worked for me

Edit | Permalink


arnoarnoAnonymous 27 Jul 2012 20:23

thanks, ├ža fonctionne pour moi for Wide & Tall. :-)
arno

Edit | Permalink


[ ottavio]ottavioAnonymous 28 Jul 2012 12:17

Thanks a million !

I followed the steps and everything gone alright !

Edit | Permalink


[ skeamer]skeamerAnonymous 29 Jul 2012 13:27

nice thanks!

Edit | Permalink


[ jj]jjAnonymous 30 Jul 2012 02:29

cheers!

Edit | Permalink


[ keki]kekiAnonymous 30 Jul 2012 08:42

thanks!

Edit | Permalink


[ rafitaFCB]rafitaFCBAnonymous 30 Jul 2012 23:49

Thanks!!!!!

Edit | Permalink


[ Murnau]MurnauAnonymous 31 Jul 2012 15:19

Great =)

Edit | Permalink


[ myke]mykeAnonymous 01 Aug 2012 14:12

Works a treat! Thanks!

Edit | Permalink


[ arriquitaun]arriquitaunAnonymous 06 Aug 2012 08:09

Worked perfectly! Thanks!!!

Edit | Permalink


[ blob]blobAnonymous 26 Aug 2012 15:42

danke! thanks!

Edit | Permalink


dandanAnonymous 27 Aug 2012 15:43

work perfect, thanks

Edit | Permalink


[ DnA]DnAAnonymous 28 Aug 2012 10:25

Thanks, it works!!

Edit | Permalink


[ chucker]chuckerAnonymous 30 Aug 2012 22:38

Thanks, work great!

Edit | Permalink


[ Babs]BabsAnonymous 30 Sep 2012 01:44

it didn't work for me… still showing empty squares and no percentages.
Running ML, changed both wide and tall. double checked and both are changed.

Edit | Permalink


[ Robert]RobertAnonymous 03 Dec 2012 00:05

Thanks - worked for me

Edit | Permalink

Lion (10.7) Comments

[ JRiggles]JRigglesAnonymous 23 Aug 2011 02:49

I'm having an issues with iStat Pro where it won't display my top processes properly. The list I get is (always) as follows: ps [0MB] tail [0MB] head [0MB] sh [0MB]. Any thoughts? OS X 10.7.1, 2.53GHz i5 MBP, 8GB RAM (2010)

Edit | Permalink

[[/module]]