Works fine in 10.8

Works fine in 10.7


Supports iCloud

Secured by Gatekeeper

Supports retina graphics

SecurID icon

Available on the Mac App Store
Not available on the Mac App Store

New patch released (4.1.1) to solve compatibility issues with Lion.

Version 4.1.1
Developer RSA
Status Works fine

0 ratings

Archived comments

No comments.6 comments

Lion (10.7) Comments

[ John]JohnAnonymous 22 Jul 2011 17:44

This app does not work for me in 32-bit or 64-bit mode. On the forums, people are confusing this app with the Cisco client itself, which does work in 32-bit mode. I get the same error in 32-bit mode as well. However, it *is* working for some people, including a co-worker of mine who has the same MacBook Pro as myself.

Edit | Permalink

[ Martin]MartinAnonymous 22 Jul 2011 18:26

I have the same problem. Did you find a way to solve this?

Edit | Permalink

[ Jose]JoseAnonymous 23 Jul 2011 02:59

Same issue. Now i'm using Windows version thru parallels.

Edit | Permalink

[ Alex]AlexAnonymous 25 Jul 2011 02:25

And I have the same problem too on my 2011 MBP.

Edit | Permalink

[ Alex]AlexAnonymous 04 Sep 2011 04:10

Downgrade to 4.0.0 version, it seems to be working

Edit | Permalink

[ Bruce]BruceAnonymous 24 Oct 2011 15:19

My previous install of 4.1.0 would not start up after upgrading to Lion. So I uninstalled via the /Library/Application Support/ script and installed a fresh copy of SecurID 4.1.1 available here:

Edit | Permalink