Podcast Maker

Doesn't work in 10.8

Works fine in 10.7

Podcast Maker

Supports iCloud

Secured by Gatekeeper

Supports retina graphics

Podcast Maker icon

Available on the Mac App Store
Not available on the Mac App Store

1.4.1 Doesn't open in Lion.

Version 1.4.1
Developer Lemonz Dream
Website http://www.lemonzdream.com/podcastmaker/
Status Doesn't work

0 ratings

1.4.1 fixes the crash issue when uploading via FTP. The app still throws up a crash report every time you close it.

Archived comments

No comments.8 comments

Lion (10.7) Comments

[ ]Anonymous 31 Jul 2011 16:45

Personally, I cannot even lauch the app :-(

Edit | Permalink

[ ]Anonymous 05 Aug 2011 17:25

Downloaded most recent version and it is not responding for me either. Have used this app for 2 years now. Very disappointed… haven't been able to get support to respond. :(

Edit | Permalink

[ Insomniac]InsomniacAnonymous 08 Aug 2011 08:38

I also can't get this to work. Support is silent, even though I have sent them several emails. I think it's time to move on to a new software, sadly. Very, very dissapointing.

Edit | Permalink

[ brump69]brump69Anonymous 09 Aug 2011 02:07

even the 1.4.1 refuses to open in lion. Have not long bought it and it did what I needed it to until I upgraded to Lion, and now I can't even open it.
No response from support.

Edit | Permalink

[ Khad Young]Khad YoungAnonymous 14 Aug 2011 06:27

Same as above. 1.4.1 (the version that allegedly resolves the Lion issue) still does not work for me in Lion. I depend on this, so I still boot to Snow Leopard to post a new podcast episode every week. Also, like others, I have not received a single email response from Lemonz Dream. Very disappointed at the lack of communication. I was excited about the update, but it changed nothing for me.

Edit | Permalink

[ akdcen]akdcenAnonymous 30 Aug 2011 03:11

1.4.1 opens and seems to work fine for me on OS X 10.7.1.

Edit | Permalink

[ m]mAnonymous 19 Oct 2011 07:40

Works again on 10.7.2

Edit | Permalink

[ Cedx]CedxAnonymous 21 Oct 2011 23:44

I confirm, works again with 10.7.2 :-)

Edit | Permalink