Protector Suite

Unknown in 10.8

Doesn't work in 10.7

Protector Suite

Supports iCloud

Secured by Gatekeeper

Supports retina graphics

Protector Suite icon

Available on the Mac App Store
Not available on the Mac App Store
Version 2.0
Developer UPEK
Status Unknown

0 ratings

Archived comments

No comments.5 comments

[ meh]mehAnonymous 25 Apr 2012 15:00

TS 5.0 is a terrible "upgrade"

It eliminates the two factor authentication present in version 2.0

Who "upgrades" a product and eliminates critical features?

Edit | Permalink

Lion (10.7) Comments

iWoziWozAnonymous 20 Jul 2011 15:53

This is the answer from AuthenTec, Inc.:

Yes, please uninstall the TrueSuite/ProtectorSuite before installing MAC OS-X Lion. The current version of TS/PS doesn't support this operating system.

We are already working on a brand new application for MAC (TrueSuite 5), it will of course support the Lion, so please keep checking our web pages for updates!

Edit | Permalink

[ Madokan]MadokanAnonymous 21 Sep 2011 00:03

we are waitin and waiting and waiting for lion support… when TruSuite 5 for Mac wille be finished?

Edit | Permalink

[ eng_asfour]eng_asfourAnonymous 23 Sep 2011 22:54

i get bored of waiting
will be the new product available soon or by the new product of mac (after lion????)
lazy developers ….!!!!!!!!!!

Edit | Permalink

[ iWoz]iWozAnonymous 12 Jan 2012 08:24

TrueSuite 5 is available and it works:

Edit | Permalink